Back
Maintenance

Scheduled Database Upgrade

Completed 24 Sep at 01:00am EDT.

Communitrak Web App Communitrak Sites Messages Alerts Auto Pay Processing
Completed

Maintenance completed

Posted 24 Sep at 01:00am EDT.
Started

The Communitrak platform will be unavailable for scheduled database upgrades that will bring enhancements to the user experience.

Posted 23 Sep at 10:00pm EDT.