Back
Maintenance

Scheduled System Upgrades

Completed 9 Apr at 04:00pm EDT.

Communitrak Web App Communitrak Sites Auto Pay Processing
Completed

Maintenance completed

Posted 9 Apr at 04:00pm EDT.
Started

We will be performing various upgrades across several of our systems. During this time, access to the Communitrak platform may be lost intermittently. Thanks for your patience as we work to enhance our product.

Posted 9 Apr at 01:00pm EDT.