Back
Maintenance

Server Upgrades

Completed 23 May at 03:30am EDT.

Communitrak Web App Communitrak Sites Auto Pay Processing
Completed

Maintenance completed

Posted 23 May at 03:30am EDT.
Started

We will be performing some upgrades on the servers that run the Communitrak platform.

Posted 23 May at 02:00am EDT.