Back
Maintenance

Server Upgrades

Completed 6 Jun at 02:00am EDT.

Communitrak Web App Auto Pay Processing
Completed

Maintenance completed

Posted 6 Jun at 02:00am EDT.
Started

We will be performing scheduled upgrades to the servers that power the Communitrak platform. Services provided by Communitrak may be intermittently unavailable during this time.

Posted 5 Jun at 09:30pm EDT.