Back
Resolved

Auto Payment Issue

Started 1 Sep at 08:00pm EDT.

Auto Pay Processing
Created

Auto Pay processing experienced a brief downtime resulting in some payments not processing as scheduled. This issue has been resolved, and all payments have been submitted for processing.

Posted 1 Sep at 08:00pm EDT.