Back
Maintenance

Scheduled Database Upgrade

Completed 9 Feb at 02:00am EST.

Communitrak Web App Auto Pay Processing
Completed

Maintenance completed

Posted 9 Feb at 02:00am EST.
Started

The Communitrak platform will be unavailable February 8, 2022 for scheduled database upgrades beginning at 8:00 pm through 2:00 am (EST). Websites provided by Communitrak will not be impacted.

Posted 8 Feb at 08:00pm EST.